Viber installation on Ubuntu 18.04 or Mint 19 [libcurl3 to libcurl4]


Download Viber Package
Let’s start by downloading the official Viber Debian package by using the wget command:

After execution of the above command you should find Viber’s installation package within your home directory:

Install Viber
Warning:
As pointed out by our readers ( see comments below ) the following Viber installation procedure will inadvertently remove libcurl4 from your system and replace it by libcurl3 package due to improper Viber package dependency definition. From this reason you are recommended to install Viber by using the following set of commands in order to preserve libcurl4 state on your system.

Alternatively, repackage the viber.deb package ( thanks Aleksey Komarov ):


Edit viber/DEBIAN/control and repace “libcurl3” with “libcurl4”

At the time of writing the Viber package seems to be a little bit troublesome and unmaintained. The default DEB installers including gdebi fails to fetch prerequisites and the Viber installation attempt results in the error:

The solution to installing Viber on Ubuntu 18.04 / Mint 19 is to explicitly include the libcurl3 package prerequisite as part of the apt installation command:

Start Viber
To start Viber application you can either run:

You can always use my modified-ready viber file from https://drive.google.com/open?id=1WivaIXHvfwc_KIFSpY9xGTdsvSH_rkTI
Source : https://linuxconfig.org/how-to-install- … aver-linux


Tags:

Επικοινωνια

Στείλε μου μήνυμα

Sending

©[2017] karanik.gr

Log in with your credentials

Forgot your details?